BUG REPORT - #17243

Modérateur: djbenp

BUG REPORT - #17243

Message par ClownShoes » 28 Mars 2013 23:46

Hello,

There seems to be a scoring bug when one is using player board #1 in the Advanced game type.

If you choose any place other than the center space for your starting castle, when you place a castle on that center space, the region does not score.

Here is my game, for reference:

http://www.boiteajeux.net/jeux/cdb/partie.php?id=17243
Game ID#17243

After placing a castle hex on the center space in Phase A, I should have scored 11 points, right?
ClownShoes
 
Message(s) : 4
Inscription : 09 Déc 2011 8:06

Re: BUG REPORT - #17243

Message par diplojak » 29 Mars 2013 0:11

indeed, it looks odd. I am going to check.

However fixing this bug (if it has to be fixed) would mean that you have the opportunity to close one more region than when starting in the middle of the board... looks odd too, don't you think?
Avatar de l’utilisateur
diplojak
Administrateur
 
Message(s) : 7177
Inscription : 28 Jan 2004 13:38
Localisation : Lille - FRANCE

Re: BUG REPORT - #17243

Message par KlausKnechtskern » 04 Avr 2013 0:55

This was reported to me by a friend also. This does not happen if you place the castle with a non dice action (e.g. the 11 points would have been scored, when placed using another castle)
KlausKnechtskern
 
Message(s) : 34
Inscription : 18 Jan 2013 11:34
Localisation : ..

Re: BUG REPORT - #17243

Message par diplojak » 04 Avr 2013 9:14

I failed to reproduce with a dice action... same board as ClownShoes, same starting point, but I scored 11 pts :scratch:
Avatar de l’utilisateur
diplojak
Administrateur
 
Message(s) : 7177
Inscription : 28 Jan 2004 13:38
Localisation : Lille - FRANCE

Re: BUG REPORT - #17243

Message par diplojak » 04 Avr 2013 13:45

I totally changed the code about closing of region, which didn't seem wrong but was far too much complicated anyway. If it happened again, please report before validating your turn...
Avatar de l’utilisateur
diplojak
Administrateur
 
Message(s) : 7177
Inscription : 28 Jan 2004 13:38
Localisation : Lille - FRANCE

Re: BUG REPORT - #17243

Message par KlausKnechtskern » 04 Avr 2013 14:30

diplojak a écrit :I totally changed the code about closing of region, which didn't seem wrong but was far too much complicated anyway. If it happened again, please report before validating your turn...


If I remember correctly it depended whether one had to use workers to close the region. I think the basic problem was that for standard play this region was already closed beforehand as it was the starting region
KlausKnechtskern
 
Message(s) : 34
Inscription : 18 Jan 2013 11:34
Localisation : ..

Re: BUG REPORT - #17243

Message par diplojak » 04 Avr 2013 15:18

KlausKnechtskern a écrit :If I remember correctly it depended whether one had to use workers to close the region.

interesting. I will check.
Avatar de l’utilisateur
diplojak
Administrateur
 
Message(s) : 7177
Inscription : 28 Jan 2004 13:38
Localisation : Lille - FRANCE


Retour vers Die Burgen von Burgund

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 1 invité

cron